Smite PS4 Match Making Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 08, 2018 - 14:13 EDT
Monitoring
We have implemented a fix and logins have resumed. We are continuing to monitor the situation.
Posted 3 months ago. Jul 08, 2018 - 12:47 EDT
Identified
We are pausing logins to fix the issue with queues in #Smite #PS4
Posted 3 months ago. Jul 08, 2018 - 12:40 EDT
This incident affected: Smite (Smite PS4).