Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart has been completed for #Paladins #Xbox #PC #Switch and #PS4.
Posted 11 days ago. Sep 11, 2019 - 10:59 EDT
Investigating
We are performing an emergency restart on #Paladins #Crossplay. We apologize for the inconvenience and will have the game back up shortly.
Posted 11 days ago. Sep 11, 2019 - 10:50 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).