Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Dec 20, 2020 - 08:05 EST
Investigating
We are preforming a restart for Realm Royale.
Posted Dec 20, 2020 - 07:34 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).