Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted about 1 month ago. Feb 27, 2017 - 09:15 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 month ago. Feb 27, 2017 - 09:04 EST
This incident affected: Paladins PC.