Paladins PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins PS4 issue has been resolved.
Posted 17 days ago. Nov 29, 2017 - 06:11 EST
Identified
Issue has been identified and currently working to resolve.
Posted 17 days ago. Nov 29, 2017 - 05:37 EST
Investigating
Automated services have detected a possible problem with #Paladins PS4. We are investigating.
Posted 17 days ago. Nov 29, 2017 - 05:26 EST
This incident affected: Paladins PS4.