Paladins Switch/Xbox Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Paladins #Switch & #Xbox login issue has been resolved.
Posted 11 days ago. Dec 03, 2018 - 10:55 EST
Investigating
We are currently investigating a login issue with #Paladins #Switch & #Xbox.
Posted 11 days ago. Dec 03, 2018 - 10:21 EST
This incident affected: Paladins (Paladins Xbox, Paladins Switch).