Realm Royale PC Shop Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 18 days ago. Mar 01, 2019 - 17:49 EST
Investigating
We are currently looking at issues with accessing the Shop on PC platform.
Posted 18 days ago. Mar 01, 2019 - 05:45 EST
This incident affected: Realm Royale (Realm Royale PC).