Paladins PC showing as down on Launcher
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted 25 days ago. Apr 05, 2017 - 09:35 EDT
Update
We are working on a fix for this Paladins PC issue, no ETA as of yet# PaladinsPC
Posted 25 days ago. Apr 05, 2017 - 08:48 EDT
Update
We are still investigating this Paladins PC issue, sorry for the inconvenience #PaladinsPC
Posted 25 days ago. Apr 05, 2017 - 08:14 EDT
Investigating
Launcher is showing Paladins PC as DOWN, We are investigating this Paladfins PC issue. #PaladinsPC
Posted 25 days ago. Apr 05, 2017 - 07:36 EDT
This incident affected: Paladins PC.