Realm Royale Crossplay & PS4 Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale #PC, #PS4, #Switch, & #Xbox login issue has been resolved.
Posted 3 months ago. May 30, 2019 - 13:20 EDT
Identified
We are working on an issue with #RealmRoyale #PC, #PS4, #Switch, & #Xbox logins
Posted 3 months ago. May 30, 2019 - 13:13 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).