Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 09, 2017 - 00:08 EST
Monitoring
We are currently monitoring the SMITE PS4 environment. #SMITE #PS4
Posted 4 months ago. Mar 08, 2017 - 23:39 EST
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 4 months ago. Mar 08, 2017 - 23:23 EST
This incident affected: Smite PS4 - North America / Europe.