Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 01, 2019 - 19:03 EST
Investigating
Automated services have detected a possible patcher issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted 3 months ago. Mar 01, 2019 - 15:52 EST