All Games Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
We have restarted all the games and they are operational. We apologize for the inconvenience this has caused. Thank you for your patience!
Posted Jun 17, 2020 - 10:58 EDT
Investigating
We are currently investigating an issue with all Hi-Rez games. We will update accordingly.
Posted Jun 17, 2020 - 10:07 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch), Tribes Ascend (Tribes Ascend PC), Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch), and SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).