Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved#smite
Posted about 1 year ago. Mar 28, 2016 - 16:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Mar 28, 2016 - 16:39 EDT