Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 11, 2016 - 22:09 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 1 year ago. Mar 11, 2016 - 22:03 EDT