Connectivity Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Connectivity has been restored for the effected users. #Smite #Paladins
Posted 4 months ago. Jun 13, 2017 - 21:49 EDT
Investigating
We are aware of some of the issues our users are experiencing with connectivity.
We are working to restore services for these users and appreciate your patience.
#Smite #Paladins
Posted 4 months ago. Jun 13, 2017 - 21:32 EDT
This incident affected: Smite PC - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, and Paladins PS4.