Smite PC Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 13, 2018 - 14:34 EST
Identified
Smite PC is experiencing an issue at this time. We are in the process of implementing a fix as soon as possible.
Posted 5 months ago. Feb 13, 2018 - 13:49 EST
This incident affected: Smite (Smite PC).