Smite PC issue detected
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #PC has been resolved and logins have returned to normal
Posted 5 months ago. Jun 06, 2017 - 15:21 EDT
Monitoring
#Smite #PC servers are back up and we will continue to monitor the situation
Posted 5 months ago. Jun 06, 2017 - 14:58 EDT
Investigating
We are investigating an issue with #Smite #PC
Posted 5 months ago. Jun 06, 2017 - 14:41 EDT