Smite Xplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency Restart has been completed. We are keeping an eye on things.
Posted 2 months ago. Aug 09, 2019 - 07:25 EDT
Investigating
We are performing an emergency restart for Smite Xplay
Posted 2 months ago. Aug 09, 2019 - 07:09 EDT
This incident affected: SMITE (SMITE PC, SMITE Xbox, SMITE Switch).