Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 10, 2017 - 19:26 EDT
Identified
We will be limiting logins to help alleviate issues affecting Match making on #Smite #XBox
Posted about 1 month ago. Feb 10, 2017 - 19:05 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 month ago. Feb 10, 2017 - 18:53 EDT
This incident affected: Smite Xbox - North America / Europe.