Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 28, 2017 - 17:17 EDT
Monitoring
We have identified and are monitoring the issues with Smite XBOX. #SMITE
Posted about 2 months ago. Jan 28, 2017 - 16:54 EDT
Update
We are currently looking into issues with Smite XBOX. #SMITE
Posted about 2 months ago. Jan 28, 2017 - 16:51 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 2 months ago. Jan 28, 2017 - 16:46 EDT
This incident affected: Smite Xbox - North America / Europe.