Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 01, 2017 - 13:11 EST
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 5 months ago. Feb 01, 2017 - 12:35 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, Tribes Ascend, and Smite Tactics.