Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 24, 2017 - 17:23 EDT
Monitoring
We are currently monitoring Smite PC.
Posted May 24, 2017 - 17:14 EDT
Identified
We are currently working on restoring Smite PC.
Posted May 24, 2017 - 17:09 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted May 24, 2017 - 17:02 EDT
This incident affected: SMITE (SMITE PC).