Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved.#smite
Posted 6 months ago. Dec 26, 2016 - 14:36 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 6 months ago. Dec 26, 2016 - 13:41 EST
This incident affected: Smite PC - North America / Europe.