PSN Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 28, 2018 - 20:16 EDT
Identified
The Playstation Network is currently experiencing issues. These issues are affecting all of our games on the PS4 platform. You can view the PSN status here: https://status.playstation.com
Posted 4 months ago. Jul 28, 2018 - 19:13 EDT
This incident affected: Smite (Smite PS4), Hand of the Gods (Hand of the Gods PS4), and Paladins (Paladins PS4).