Smite XBox & Paladins XBox Purchasing Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 13, 2018 - 11:14 EDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Jul 12, 2018 - 23:06 EDT
Investigating
We are currently investigating an issue players are having when trying to make purchases on XBox.
Posted 5 months ago. Jul 12, 2018 - 21:01 EDT
This incident affected: Smite (Smite Xbox), Hand of the Gods (Hand of the Gods Xbox), and Paladins (Paladins Xbox).