Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved. #SmiteXBOX
Posted 12 days ago. Apr 18, 2017 - 17:28 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 12 days ago. Apr 18, 2017 - 16:55 EDT
This incident affected: Smite Xbox - North America / Europe.