Web Store Purchases
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 02, 2019 - 23:17 EST
Identified
There is currently an issue with the web store that is preventing player from purchasing items and in-game currency. We are working to resolve the issue as soon as possible.
Posted 3 months ago. Mar 02, 2019 - 18:48 EST
This incident affected: Paladins (Paladins PC) and Smite (Smite PC).