Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 05, 2018 - 12:49 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 9 months ago. Mar 05, 2018 - 12:15 EST