Paladins PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PS4 has been resolved.
Posted 22 days ago. Sep 29, 2017 - 20:29 EDT
Monitoring
#Paladins #PS4 logins have resumed and we are continuing to monitor.
Posted 22 days ago. Sep 29, 2017 - 19:17 EDT
Identified
We are temporarily pausing logins for #Paladins #PS4
Posted 22 days ago. Sep 29, 2017 - 18:55 EDT
Investigating
Automated services have detected a possible problem with #Paladins PS4. We are investigating.
Posted 22 days ago. Sep 29, 2017 - 18:54 EDT
This incident affected: Paladins PS4.