Paladins Xbox/Switch Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 28, 2018 - 05:37 EDT
Update
Paladins Switch services look to be normalizing. We are monitoring the results.
Posted 3 months ago. Aug 28, 2018 - 05:22 EDT
Update
Paladins Xbox services look to be normalizing, however, at this time, some Paladins Switch users are still experiencing difficulties; we are continuing to monitor the situation and will provide further updates as warranted.
Posted 3 months ago. Aug 28, 2018 - 01:25 EDT
Monitoring
Paladins Switch and Xbox Emergency Restart has been completed and we are monitoring the results.
Posted 3 months ago. Aug 28, 2018 - 00:31 EDT
Identified
We will be performing an emergency restart for Paladins Switch and Paladins Xbox. The game will be back as soon as possible.
Posted 3 months ago. Aug 27, 2018 - 23:41 EDT
This incident affected: Paladins (Paladins Xbox, Paladins Switch).