Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 12, 2016 - 14:39 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 year ago. Mar 12, 2016 - 14:23 EST