Loggin Issues For All Platforms and Games
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Dec 23, 2015 - 15:45 EST
Investigating
We are checking into it
Posted almost 2 years ago. Dec 23, 2015 - 15:05 EST