Realm Royale Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 18 days ago. Aug 06, 2019 - 03:48 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 18 days ago. Aug 06, 2019 - 03:32 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. Aug 06, 2019 - 03:27 EDT
Investigating
We will be performing an emergency restart of Realm Royale Crossplay. The game will be back shortly.
Posted 18 days ago. Aug 06, 2019 - 03:13 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale Xbox, Realm Royale Switch).