Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 30, 2017 - 17:15 EDT
Monitoring
We have resumed logins for SMITE XBOX
Posted about 2 months ago. Jan 30, 2017 - 17:01 EDT
Identified
We are currently working on restoring service for SMITE XBOX.
Posted about 2 months ago. Jan 30, 2017 - 16:47 EDT
Monitoring
We are currently monitoring SMITE XBOX. Logins have be resumed.
Posted about 2 months ago. Jan 30, 2017 - 16:14 EDT
Identified
We are currently woking on issues with SMITE XBOX. #SMITE XBOX
Posted about 2 months ago. Jan 30, 2017 - 15:58 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 2 months ago. Jan 30, 2017 - 15:51 EDT
This incident affected: Smite Xbox - North America / Europe.