Paladins and Smite Web Store Issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
The web store has been fixed.
Posted 3 months ago. May 13, 2019 - 12:43 EDT
Investigating
We are looking into players being unable to access the web store and in game stores.
Posted 3 months ago. May 13, 2019 - 09:33 EDT
This incident affected: Smite (Smite PC) and Paladins (Paladins PC).