Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 22, 2017 - 20:16 EDT
Identified
We have identified an issue with #SmitePC North America capacity; we are working to address and will provide additional updates shortly.
Posted 9 months ago. Mar 22, 2017 - 20:11 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 9 months ago. Mar 22, 2017 - 20:06 EDT
This incident affected: Smite PC - North America / Europe.