Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 28, 2017 - 18:32 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 2 months ago. Jan 28, 2017 - 18:21 EDT
This incident affected: Smite Xbox - North America / Europe.