Smite PC Brazil Servers
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #smite
Posted 7 months ago. Sep 02, 2016 - 08:06 EDT
Update
We are still working on the smite pc brazil servers, estimated time for them to be up is 7:30am edt / 1:30pm cest#smite
Posted 7 months ago. Sep 02, 2016 - 06:55 EDT
Investigating
We are working to get Smite PC Brazil Servers online, should be back online with in 1 hr#smite
Posted 7 months ago. Sep 02, 2016 - 05:47 EDT