Paladins PC - Ongoing Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 22, 2017 - 18:09 EDT
Update
We will be patching Paladins PC tomorrow to address issues with the game.
Posted about 1 month ago. Feb 22, 2017 - 18:09 EDT
Monitoring
We are currently working on issues with Paladins PC. #PALADINS PC
Posted about 1 month ago. Feb 22, 2017 - 10:05 EDT
This incident affected: Paladins PC.