Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 26, 2017 - 04:54 EDT
Monitoring
We have restored Smite PC. We are continuing to monitor. #SMITE #PC
Posted 5 months ago. Mar 26, 2017 - 04:24 EDT
Update
We are looking into issues with Smite PC. #SMITE #PC
Posted 5 months ago. Mar 26, 2017 - 03:57 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Mar 26, 2017 - 03:49 EDT
This incident affected: Smite PC - North America / Europe.