Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of Smite PC has been completed
Posted 10 months ago. Jan 10, 2018 - 10:44 EST
Identified
We will be performing an emergency restart of Smite PC momentarily
Posted 10 months ago. Jan 10, 2018 - 10:25 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 10 months ago. Jan 10, 2018 - 10:12 EST