Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved#smite
Posted over 1 year ago. Apr 18, 2016 - 12:42 EDT
Identified
We are currently investigating the issues effecting logins on #Smite #PS4.
Posted over 1 year ago. Apr 18, 2016 - 12:26 EDT
Update
Investigating: We are currently investigating this Smite PS4 issue#smite
Posted over 1 year ago. Apr 18, 2016 - 12:23 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted over 1 year ago. Apr 18, 2016 - 12:21 EDT