Smite Xbox Match Making issues
Incident Report for Hi-Rez Studios, Inc
Resolved
We are completed with our restart of smite on xbox.
#SMITE
Posted about 2 years ago. Dec 15, 2015 - 12:37 EST
Update
The restart for smite on xbox will be delayed to slightly later in the afternoon (12:00 -12:30 PM).
#SMITE
Posted about 2 years ago. Dec 15, 2015 - 11:29 EST
Identified
We have identified the issues with xbox and will require another restart to fully resolve. This restart will happen at approximately 11-1130am EST #smite
Posted about 2 years ago. Dec 15, 2015 - 10:35 EST
Update
We are performing a restart for smite on XBOX to alleviate the issues with match making and logins.
Posted about 2 years ago. Dec 15, 2015 - 09:35 EST
Investigating
We are aware of the issues with logins, and match making in smite for xbox.
We are working to resolve these issues in a timely manner, sorry for the inconvenience.
#SMITE
Posted about 2 years ago. Dec 15, 2015 - 09:26 EST