Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
XBox Live is still reporting issues, however impact to #SMITE is no longer degrading performance.
Posted about 1 year ago. Feb 23, 2016 - 00:52 EDT
Monitoring
Ongoing XBox Live issues are impacting #SMITE on the XBox One: http://support.xbox.com/en-US/xbox-live-status?icid=furl_status
Posted about 1 year ago. Feb 22, 2016 - 21:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Feb 22, 2016 - 21:29 EDT