Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This paladins pc incident has been resolved. #paladinspc
Posted 7 months ago. Mar 02, 2017 - 09:19 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Mar 02, 2017 - 09:04 EST
This incident affected: Paladins PC.