Paladins PC Servers Down
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 07, 2018 - 11:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Jun 07, 2018 - 11:46 EDT
Investigating
We are currently investigating an issue with Paladins PC servers.
Posted 6 months ago. Jun 07, 2018 - 11:03 EDT
This incident affected: Paladins (Paladins PC).