Smite PS4 sales not processing
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PS4 sales not processing
Posted about 1 year ago. Sep 30, 2016 - 12:13 EDT
Investigating
#Smite PS4 sales are not going through due to a PSN interface problem -we are investigating.
Posted about 1 year ago. Sep 30, 2016 - 09:26 EDT