Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC issues have been resolved; all systems normal.
Posted 2 months ago. Jan 13, 2017 - 18:34 EDT
Monitoring
#SMITE PC restart is complete and game is open; we are continuing to monitor.
Posted 2 months ago. Jan 13, 2017 - 18:15 EDT
Identified
#SMITE PC will receive an emergency restart; game back shortly.
Posted 2 months ago. Jan 13, 2017 - 18:07 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 2 months ago. Jan 13, 2017 - 18:05 EDT
This incident affected: Smite PC - North America / Europe.