Smite Xbox Issue Detected
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved.
Posted 11 days ago. Jun 13, 2017 - 22:27 EDT
Identified
We are pausing logins temporarily for #Smite #Xbox
We apologize for the inconvenience.
Posted 11 days ago. Jun 13, 2017 - 21:52 EDT
Investigating
We are investigating an issue with #Smite #Xbox
Posted 11 days ago. Jun 13, 2017 - 21:50 EDT
This incident affected: Smite Xbox - North America / Europe.