Smite PC Login/Match Manager Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC incident has been resolved.
Posted 12 days ago. Jul 10, 2018 - 10:33 EDT
Update
Logins have resumed for #Smite #PC. We are monitoring the results.
Posted 12 days ago. Jul 10, 2018 - 10:04 EDT
Update
We are temporarily limiting logins for #Smite #PC to address an issue with Match Manager.
Posted 12 days ago. Jul 10, 2018 - 10:00 EDT
Monitoring
The #Smite #PC emergency restart has been completed. We are monitoring the results.
Posted 12 days ago. Jul 10, 2018 - 09:31 EDT
Identified
We are performing an emergency restart for #Smite #PC. Game will be back up soon.
Posted 12 days ago. Jul 10, 2018 - 09:00 EDT
Investigating
We are investigating an issue affecting #Smite #PC logins. Players may be expereincing 'Game is Down' in launcher.
Posted 12 days ago. Jul 10, 2018 - 08:53 EDT
This incident affected: Smite (Smite PC).